•  
  • 一点兴趣
  • 计算机等级考试四级网络工程师必备考点总结

计算机等级考试四级网络工程师必备考点总结

Categories: 一点兴趣
Comments: No Comments
Published on: 2011 年 03 月 25 日

1
网络系统统结构与设计的基本原则:

计算机网络按地理范围划分为 局域网 , 城域网 , 广域网

局域网提供 高数据传输速率 10mbps-10gbps , 低误码率的高质量传输环境

局域网按 介质访问控制方法 角度分为 共享介质式局域网 和 交换式局域网

局域网按 传输介质类型 角度分为 有线介质局域网 和无线通信信道的 无线介质局域网

早期的计算机网络主要是广域网 ,分为主计算机与终端(负责数据处理)和通信处理设备与通信电路 (负责

数据通信处理)

计算机网络从逻辑功能上分为 资源子网 和 通信子网

资源子网(计算机系统,终端,外网设备以及软件信息资源)负责全网数据处理业务,提供网络资源与服务

通信子网(通信处理控制机 — 即网络节点,通信线路及其他通信设备)网络数据传输,转发等通信处理任务

网络接入(局域网,无线局域网,无线城域网,电话交换网,有线电视网)

广域网投资大管理困难,由电信运营商组建维护

广域网技术主要研究的是远距离,宽带,高服务质量的核心交换技术,用户接入技术由城域网承担。

广域网典型网络类型和技术(公共电话交换网,综合业务数字网,数字数据网,x.25分组交换网,帧中继网,异步

传输网,以太网 )

交换局域网的核心设备是局域网交换机

城域网概念:网络运营商在城市范围内提供各种信息服务,以宽带光传输网络为开放平台,以TCPIP协议为基础

密集波分复用技术的推广导致广域网主干线路带宽扩展

城域网分为核心交换层(高速数据交换),边缘汇聚层(路由与流量汇聚),用户接入层(用户接入和本地流量

控制)

层次结构优点:层次定位清楚,接口开放,标准规范,便于组建管理

核心层基本功能:( 设计重点:可靠性,可扩展性,开放性 )

连接汇聚层,为其提供高速分组转发,提供高速安全 QoS 保障的传输环境;

实现主干网络互联,提供城市的宽带 IP 数据出口;

提供用户访问 INTERNET 需要的路由服务;

汇聚层基本功能:

汇聚接入层用户流量,数据分组传输的汇聚,转发与交换;

本地路由过滤流量均衡, QoS 优先管理,安全控制, IP 地址转换,流量整形;

把流量转发到核心层或本地路由处理;

设计初期只需要采用核心层与汇聚层

城域网设计重要出发点 :在降低网络造价的前提下,系统能够满足当前的数据 交

换量,接入的用户数与业务类型的要求,并具有可扩展能力。

组建运营宽带城域网原则 :可运营性,可管理性,可盈利性,可扩展性

管理和运营宽带 城域网关键技术 :带宽管理,服务质量 QoS ,网络管理,用户 管

理,多业务接入,统计与计费, IP 地址分配与地址转换,网络安全

宽带城域网在组建方案中一定要按照 电信级运营要求 (考虑设备冗余,线路冗 余

以及系统故障的快速诊断与自我恢复)

服务质量 QoS QoS QoS QoS 技术 :资源预留,区分服务,多协议标记转换

管理带宽城域网 3 3 3 3 种基本方案 :带内网络管理,带外 ~~ ,同时使用带内带外 ~~

带内:利用 传统电信网络 进行网络管理,利用数据通信网或公共交换电话网拨 号 ,

对网络设备进行数据配置。

带外:利用 IP 网络及协议 进行网络管理,利用网络管理协议建立网络管理系统 。

对汇聚层及其以上设备采用带外管理,汇聚层一下采用带内管理

宽带城域网要求的管理能力 表现在电信级的接入管理,业务管理,网络安全

网络安全技术方面需要解决物理安全,网络安全和信息安全。

宽带城域网基本技术与方案( SDH 城域网方案; 10GE 城域网方案,基于 ATM

城域网方案)

光以太网由多种实现形式 ,最重要的有 10GE 技术和弹性分组环技术

同样规模城域网, 光以太网造价 是 SONET 的 1/5 是 ATM 的 1/10

IEEE 已经对 10mbps 100mbps 1gbps 到 10gbps 以太网技术标准化啦。 100gbps 的

以太网技术标准正在研究

弹性分组环( RPR RPR RPR RPR ) :直接在光纤上高效传输 IP 分组的传输技术

标准: IEEE802.17

目前 城域网主要拓扑结构 :环形结构

核心层有 3 — 10 个结点 的城域网使用环形结构可以简化光纤配置

功能 :简化光纤配置;解决网络保护机制与带宽共享问题;提供点到多点业务

弹性分组环采用双环结构这点与 FDDI 结构相同

RPR 结点最大长度 100km ,顺时针为外环,逆时针为内环

RPR RPR RPR RPR 技术特点: (带宽利用率高;公平性好;快速保护和恢复能力强;保证服 务

质量)

用户接入网主要有三类 :计算机网络,电信通信网,广播电视网

接入网接入方式主要为五类 :地面有线通信系统,无线通信和移动通信网,卫 星

通信网,有线电视网和地面广播电视网

三网融合 :计算机网络,电信通信网,电视通信网

用户接入角度 : 接入技术 (有线和无线), 接入方式 (家庭接入,校园接入,机

关与企业人)

目前宽带接入技术 :数字用户线 XDSL 技术,光纤同轴电缆混合网 HFC 技术,

光纤接入技术,无线接入技术,局域网技术

无线接入分为 无线局域网接入,无线城域网接入,无线 Ad hoc 接入

局域网标准: 802.3 无线局域网接入: 802.11 无线城域网: 802.16

数字用户线 XDSL XDSL XDSL XDSL 又叫 数字用户环路 ,基于电话铜双绞线高速传输技术

技术分类: ADSL 非对称数字用户线 速率不对称 1.5mbps/64kbps-5.5k m

RADSL 速率自适应数字用户线 速率不对称 1.5mbps/64kbps-5.5km

HDSL 高比特率数字用户线 速率对称 1.544mbps (没有距离影响 )

VDSL 甚高比特率数字用户线 速率不对 51mbps/64kbps( 没有影响 )

光纤同轴混合网 HFC 是新一代有线电视网

电话拨号上网速度 33.6kbps — 56.6kbps

有线电视接入宽带,数据传输速率 10mbps — 36mbps

电缆调制解调器 Cable Cable Cable Cable modem modem modem modem 专门为利用有线电视网进行数据传输而

设计

上行信道: 200kbps-10mbps 下行信道: 36mbps

类型 :传输方式(双向对称传输和非对称式传输)

数据传输方向(单向,双向)

同步方式(同步和异步交换)

接入角度(个人 modem 和宽带多用户 modem )

接口角度(外置式,内置式和交互式机顶盒)

无源光网络技术( APON )优点

系统稳定可靠

可以适应不同带宽,传输质量的要求

与 CATV 相比,每个用户可占用独立带宽不会发生拥塞

接入距离可达 20km — 30km

802.11b 定义直序扩频技术,速率为 1mbps 2mbps 5.5mbps 11mbps

802.11a 提高到 54mbps

中小型网络系统总体规划与设计方法

网络运行环境主要包括机房和电源

机房是放置核心路由器,交换机,服务器等 核心设备

UPS 系统供电:稳压,备用电源,供电电压智能管理

网络操作系统: NT,2000,NETWARE,UNIX,LINUX

网络应用软件开发与运行环境:网络数据库管理系统与网络软件开发工具

网络数据库管理系统: Oracle , Sybase , SOL , DB2

网络应用系统:电子商务系统,电子政务系统,远程教育系统,企业管理系统,

校园信息服务系统,部门财务管理系统

网络需求调研和系统设计基本原则 :共 5 点

(其中考点 4 :大型网络系统的建设需要聘请 专业的监理公司 对项目进行 监理 )

制定项目建设任务书后,确定网络信息系统建设任务后,项目承担单位 首要任 务

是 网络用户调查和网络工程需求分析

需求分析是设计建设与运行网络系统的关键

网络结点地理位置分布情况: (用户数量及分布的位置;建筑物内部结构情况调

查;建筑物群情况调查)

网络需求详细分析: (网络总体需求设计;结构化布线需求设计;网络可用性与

可靠性分析;网络安全性需求分析;网络工程造价分析)

结点 2-250 可不设计接入层和汇聚层

结点 100-500 可不设计接入层

结点 250-5000 一般需要 3 层结构设计

核心层网络一般承担整个网络流量的 40%-60% 标准 GE 10GE

层次之间上联带宽:下联带宽一般控制在 1 : 20

( 10 个交换机,每个有 24 个接口,接口标准是 10/100mbps :那么上联带宽是

24*100*10/20 大概是 2gbps )

高端路由器 ( 背板大于 40gbps) 高端核心路由器 支持 mpls

中端路由器(背板小于 40gbps ) 企业级路由器 支持 IPX,VINES , QoS VPN

低端路由器(背板小于 40gbps ) 支持 ADSL PPP

路由器关键技术指标 :

1 :吞吐量(包转发能力)

2 :背板能力(决定吞吐量) 背板 : router 输入端和输出端的物理通道

传统路由采用共享背板结构,高性能路由采用交换式结构

3 :丢包率(衡量 router 超负荷工作性能)

4 :延时与延时抖动(第一个比特进入路由到该帧最后一个离开路由的时间)

高速路由要求 1518B 的 IP 包,延时小于 1ms

5 :突发处理能力

6 :路由表容量( INTERNET 要求执行 BGP 协议的路由要存储十万路由表项, 高

速路由应至少支持 25 万)

7 :服务质量 8 :网管能力

9 :可靠性与可用性

路由器冗余:接口冗余,电源冗余,系统板冗余,时钟板冗余,整机设备冗余

热拨插是为了保证路由器的可用性

高端路由可靠性 :

( 1 ) 无故障连续工作时间大于 10 万小时

( 2 ) 系统故障恢复时间小于 30 分钟

( 3 ) 主备切换时间小于 50 毫秒

( 4 ) SDH 和 ATM 接口自动保护切换时间小于 50 毫秒

( 5 ) 部件有热拔插备份,线路备份,远程测试诊断

( 6 ) 路由系统内不存在单故障点

交换机分类:从技术类型( 10mbps Ethernet 交换机; fast Ethernet 交换机; 1gbp s

的 GE 交换机)从内部结构(固定端口交换机;模块化交换机 — 又叫机架式交 换

机)

500 个结点以上 选取企业级交换机

300 个结点以下 选取部门级交换机

100 个结点以下 选取工作组级交换机

交换机技术指标:

( 1 ) 背板带宽(输入端和输出端得物理通道)

( 2 ) 全双工端口带宽(计算:端口数 * 端口速率 *2 )

( 3 ) 帧转发速率

( 4 ) 机箱式交换机的扩张能力

( 5 ) 支持 VLAN 能力(基于 MAC 地址,端口, IP 划分)

缓冲区协调不同端口之间的速率匹配

网络服务器类型(文件服务器;数据库服务器; Internet 通用服务器;应用服务

器)

虚拟盘体分为(专用盘体,公用盘体与共享盘体)

共享硬盘服务系统缺点: dos 命令建立目录;自己维护;不方便系统效率低, 安

全性差

客户 / 服务器 工作模式采用两层结构:第一层在客户结点计算机 第二层在数据

库服务器上

Internet 通用服务器包括( DNS 服务器, E-mail 服务器, FTP 服务器, WWW 服

务器,远程通信服务器,代理服务器)

校园网或企业网要配置一台主机来安装 DNS 服务器和 E-mail 服务器

基于复杂指令集 CISC CISC CISC CISC 处理器的 Intel Intel Intel Intel 结构的服务器:

优点: 通用性好,配置简单,性能价格比高,第三方软件支持丰富,系统维护 方

便 缺点: CPU 处理能力与系统 I/O 能力较差 (不适合作为高并发应用和大型服

务器)

基于精简指令集 RISC RISC RISC RISC 结构处理器的服务器与相应 PCPCPCPC 机比: CPU 处理能力提 高

50%-75% (大型,中型计算机和超级服务器都采用 RISC RISC RISC RISC 结构处理器,操作系 统

采用 UNIX UNIX UNIX UNIX )

因此采用 RISC RISC RISC RISC 结构处理器的服务器称 UNIX UNIX UNIX UNIX 服务器

按网络应用规模划分网络服务器

( 1 ) 基础级服务器 1 个 CPU

( 2 ) 工作组服务器 1-2 个 CPU

( 3 ) 部门级服务器 2-4 个 CPU

( 4 ) 企业级服务器 4-8 个 CPU

服务器采用相关技术

( 1 ) 对称多处理技术 SMP (多 CPU 服务器的负荷均衡)

( 2 ) 集群 Cluster (把一组计算机组成共享数据存储空间)

( 3 ) 非一致内存访问( NUMA ) (结合 SMP Cluster 用于多达 64 个或更多 CPU

的服务器 )

( 4 ) 高性能存储与智能 I/O 技术(取决存取 I/O 速度和磁盘容量)

( 5 ) 服务处理器与 INTEL 服务器控制技术

( 6 ) 应急管理端口

( 7 ) 热拨插技术

网络服务器性能

( 1 ) 运算处理能力

CPU 内核:执行指令和处理数据

一级缓存:为 CPU 直接提供计算机所需要的指令与数据

二级缓存:用于存储控制器,存储器,缓存检索表数据

后端总线:连接 CPU 内核和二级缓存

前端总线:互联 CPU 与主机芯片组

C PU50% 定律: cpu1 比 cpu2 服务器性能提高 (M2-M1)/M1*50% M 为主频

( 2 ) 磁盘存储能力(磁盘性能参数:主轴转速;内部传输率,单碟容量,平 均

巡道时间;缓存)

( 3 ) 系统高可用性

99.9% 每年停机时间小于等于 8.8 小时

99.99% 每年停机时间小于等于 53 分钟

99.999% 5 分钟

服务器选型的基本原则

( 1 ) 根据不同的应用特点选择服务器

( 2 ) 根据不同的行业特点选择服务器

( 3 ) 根据不同的需求选择服务器的配置

网路攻击两种类型:服务攻击和非服务攻击

从黑客攻击手段上看分为 8 类:系统入侵类攻击;缓冲区溢出攻击,欺骗 类

攻击,拒绝服务类攻击,防火墙攻击,病毒类攻击,木马程序攻击,后门攻击

非服务攻击针对网络层等低层协议进行

网络防攻击研究主要解决的问题:

( 1 ) 网络可能遭到哪些人的攻击

( 2 ) 攻击类型与手段可能有哪些

( 3 ) 如何及时检测并报告网络被攻击

( 4 ) 如何采取相应的网络安全策略与网络安全防护体系

网络协议的漏洞是当今 Internet 面临的一个严重的安全问题

辑7

黑客攻击手段和方法一般分为主动攻击和被动攻击

网络信息安全包括信息存储安全与信息传输安全

信息传输安全过程的安全威胁(截取信息;窃听信息;篡改信息;伪造信息)

解决来自网络内部的不安全因素必须从技术和管理两个方面入手

病毒基本类型划分为 6 种:引导型病毒;可执行文件病毒;宏病毒;混合病毒,

特洛伊木马病毒; Iternet 语言病毒

灰色软件包括:间谍程序,广告程序。后门程序,下载程序,植入程序

网络系统安全必须包括 3 个机制:安全防护机制,安全检测机制,安全恢复机 制

网络系统安全设计原则:

( 1 ) 全局考虑原则

( 2 ) 整体设计的原则

( 3 ) 有效性与实用性的原则

( 4 ) 等级性原则

( 5 ) 自主性与可控性原则

( 6 ) 安全有价原则

IP 地址规划设计技术

无类域间路由技术需要在 提高 IP 地址利用率 和 减少主干路由器负荷 两个方面取

得平衡

网络地址转换 NAT NAT NAT NAT 最主要的应用 是专用网,虚拟专用网,以及 ISP 为拨号用户

提供的服务

NAT 更用应用于 ISP ,以节约 IP 地址

A 类地址: 1.0.0.0-127.255.255.255 可用地址 125 个 网络号 7 位

B 类地址: 128.0.0.0-191.255.255.255 网络号 14 位

C 类地址: 192.0.0.0-223.255.255.255 网络号 21 位 允许分配主机号 254 个

D 类地址: 224.0.0.0-239.255.255.255 组播地址

E 类地址: 240.0.0.0-247.255.255.255 保留

直接广播地址:

受限广播地址: 255.255.255.255

网络上特定主机地址:

回送地址:专用地址

全局 IP 地址是需要申请的,专用 IP 地址是不需申请的

专用地址: 10 ; 172.16- 172.31 ; 192.168.0-192.168.255

NAT NAT NAT NAT 方法的局限性

( 1 ) 违反 IP 地址结构模型的设计原则

( 2 ) 使得 IP 协议从面向无连接变成了面向连接

( 3 ) 违反了基本的网络分层结构模型的设计原则

( 4 ) 有些应用将 IP 插入正文内容

( 5 ) N at 同时存在对高层协议和安全性的影响问题

IP IP IP IP 地址规划基本步骤

( 1 ) 判断用户对网络与主机数的需求

( 2 ) 计算满足用户需求的基本网络地址结构

( 3 ) 计算地址掩码

( 4 ) 计算网络地址

( 5 ) 计算网络广播地址

( 6 ) 计算机网络的主机地址

CIDR 地址的一个重要的特点:地址聚合和路由聚合能力

规划内部网络地址系统的基本原则

( 1 ) 简洁

( 2 ) 便于系统的扩展与管理

( 3 ) 有效的路由

IPv6 地址分为 单播地址;组播地址;多播地址;特殊地址

128 位每 16 位一段

000f 可简写为 f 后面的 0 不能省

::只能出现一次

I pv6 不支持子网掩码,它只支持前缀长度表示法

路由设计基础

默认路由成为第一跳路由或缺省路由

发送主机的默认路由器又叫做源路由器,目的主机所连接的路由叫做目的路由

路由选择算法参数

跳数

带宽(指链路的传输速率)

延时(源结点到目的结点所花费时间)

负载(单位时间通过线路或路由的通信量)

可靠性(传输过程的误码率)

开销(传输耗费)与链路带宽有关

路由选择的核心:路由选择算法

算法特点:

( 1 ) 算法必须是正确,稳定和公平的

( 2 ) 算法应该尽量简单

( 3 ) 算法必须能够适应网络拓扑和通信量的变化

( 4 ) 算法应该是最佳的

路由选择算法分类 : : : :

静态路由选择算法(非适应路由选择算法)特点:简单开销小,但不能及时适 应

网络状态的变化

动态路由选择算法(自适应路由选择算法)特点:较好适应网络状态的变化, 但

实现复杂,开销大

一个自治系统最重要的特点就是它有权决定在本系统内应采取何种路由选择协

路由选择协议:内部网关协议 IGP (包括路由信息协议 RIP ,开放最短路径优 先

协议 OSPF );外部网关协议 EGP (主要是 BGP )

RIP 是内部网关协议使用得最广泛的一种协议;特点:协议简单,适合小的自 治

系统,跳数小于 15

OSPF OSPF OSPF OSPF 特点 :

OSPF 使用分布式链路状态协议( RIP 使用距离向量协议)

OSPF 要求路由发送本路由与哪些路由相邻和链路状态度量的信息( RIP 和 OSP F

都采用最短路径优先的指导思想,只是算法不同)

OSPF 要求当链路状态发生变化时用洪泛法向所有路由发送此信息( RIP 仅向相

邻路由发送信息)

OSPF 使得所有路由建立链路数据库即全网拓扑结构( RIP 不知道全网拓扑)

OSPF 将一个自治系统划分若干个小的区域,为拉适用大网络,收敛更快。每 个

区域路由不超过 200 个

区域好处:洪泛法局限在区域,区域内部路由只知道内部全网拓扑,却不知道 其

他区域拓扑

主干区域内部的路由器叫主干路由器(包括区域边界路由和自治系统边界路由)

BGP 路由选择协议的四种分组

打开分组;更新分组(是 核心 );保活分组;通知分组;

局域网技术

交换机采用采用两种 转发方式技术 :快捷交换方式和存储转发交换方式

虚拟局域网 VLA VLA VLA VLA N N N N 组网定义方法 :(交换机端口号定义; MAC 地址定义;网 络

层地址定义;基于 IP 广播组)

综合布线特点 :(兼容性;开放性;灵活性;可靠性;先进性;经济性)

综合布线系统组成 :(工作区子系统;水平子系统;干线子系统;设备间子系统 ;

管理子系统;建筑物群子系统)

综合布线系统标准 :

( 1 ) ANSI/TIA/EIA 568-A

( 2 ) TIA/EIA-568-B.1 TIA/EIA-568-B.2 TIA/EIA-568-B.3

( 3 ) ISO/IEC 11801

( 4 ) GB/T 50311-2000 GB/T50312-2000

IEEE802.3 10-BASE-5 表示以太网 10mbps 基带传输使用粗同轴电缆 max=500 m

IEEE802.3 10-BASE-2 200m

IEEE802.3 10-BASE-T 使用双绞线

快速以太网 提高到 100mbps

IEEE802.3U 100-BASE-TX MAX=100M

IEEE802.3U 100-BASE-T4 针对建筑物以及按结构化布线

IEEE802.3U 100-BASE-FX 使用 2 条光纤 max=425M

支持全双工模式的快速以太网的拓扑构型一定是星形

自动协商功能是为链路两端的设备选择 10/100mbps 与半双工 / 全双工模式中共 有

的高性能工作模式,并在链路本地设备与远端设备之间激活链路

自动协商功能只能用于使用双绞线的以太网,并且规定过程需要 500ms 内完成

中继器工作在物理层,不涉及帧结构,中继器不属于网络互联设备

10-BASE-5 协议中,规定最多可以使用 4 个中继器,连接 3 个缆段,网络中两 个

结点的最大距离为 2800m

集线器特点:

( 1 ) 以太网是典型的总线型结构

( 2 ) 工作在物理层 执行 CSMA/CD 介质访问控制方法

( 3 ) 多端口

网桥在数据链路层完成数据帧接受,转发与地址过滤功能,实现多个局域网的 数

据交换

透明网桥 IEEE 802.1D 特点:

( 1 ) 每个网桥自己进行路由选择,局域网各结点不负责路由选择,网桥对互 联

局域网各结点是透明

( 2 ) 一般用于两个 MAC 层协议相同的网段之间的互联

透明网桥使用了生成树算法

评价网桥性能参数主要是:帧过滤速率,帧转发速率

辑12

按照国际标准,综合布线采用的主要连接部件分为建筑物群配线架 (CD); 大楼 主

配线架( BD );楼层配线架( FD ),转接点( TP )和通信引出端 (TO)

TO 到 FD 之间的水平线缆最大长度不应超过 90m

设备间室温应保持在 10 度到 27 度 相对湿度保持在 30%-80%

辑13

局域网交换机基本功能 :

( 1 ) 建立和维护一个表示 MAC 地址与交换机端口对应关系的交换表

( 2 ) 发送结点和接收结点之间建立一条虚连接

( 3 ) 完成数据帧的转发或过滤

显示交换机命令:

大中型交换机: show cam dunamic

小型交换机: show mac-address-table

交换机的交换结构

( 1 ) 软件执行交换结构 ( 把数据帧由串行代码转换成并行代码 ) 特点:交换速 度

慢,交换机堆叠困难,交换机端口较多导致性能下降

( 2 ) 矩阵交换结构(完全由硬件完成,由输入,输出,交换矩阵和控制处理)

特点:交换速度快,延时小,结构紧凑,矩阵交换实现相对简单,不易 扩

展,不利于管理

( 3 ) 总线交换结构(时分多路复用技术)特点:性能好,便于堆叠扩展,易 实

现帧广播和监控管理,易实现多个输入对一个输出的帧传送的特点。

应用广泛

( 4 ) 共享存储器交换结构(无背板)特点:结构简单,易实现

适合小交换机采用

交换机有静态交换和动态交换两种方式,动态交换模式有存储转发和直通,直 通

交换模式又有快速转发交换和碎片丢弃交换

总结说有 3 模式:快速转发(通常也称直通交换模式,不提供检错纠错,适合 小

型交换机采用)碎片丢失(又称无分段模式,提前过滤冲突碎片,提高宽带利 用

率)存储转发(延时大,速度慢,可靠性高,可检错纠错,最为广泛应用)

堆叠交换机: 2-10gbps 6-8 个堆叠数量 有达 16 个的

箱体模块化交换机: 2-20 个

VLAN VLAN VLAN VLAN 技术特性 :

工作在数据链路层

每个 VLAN 都是一个独立的逻辑网段,一个独立的广播域

VLAN 之间不能直接通信,必须通过第三层路由功能完成

VLAN 标识, vlan id 用 12 位 bit 表示,支持 4096 个 vlan 1-1005 是标准范围, 其

中 1-1000 是用于以太网

交换机之间实现 trunk 功能,必须遵守相同的 vlan 协议,如思科 isl

划分 vlan

( 1 ) 基于端口划分(静态划分,最通用)

( 2 ) 基于 mac 地址(动态的划分)

( 3 ) 第三层协议类型或地址

交换机配置

duplex auto/full/half 配置端口通信方式

speed 10/100 speed auto 端口传输速率

VTP 实现 VLAN 的单一管理

Switch(config)#vtp domain todd 设置域名

Switch(config)#vtp password aaa

Switch(config)#vtp mode client /server/transparent

虚拟局域网 VLAN

查看 VLAN 命令

Switch#show vlan

创建 VLAN

Switch#config t

Switch(config)#vlan 2

Switch(config-vlan)#ex

Switch(config)#interface range fastEthernet 0/11 - 24

Switch(config-if-range)#switchport access vlan 2

书上是( vlan data

vlan 1000 name vlan1000 建立,修改 vlan

no vlan 1000 删除 vlan

interface f0/1

switchport access vlan 1000)

Switch(config)#interface vlan 1

Switch(config-if)#ip address 192.168.0.100 255.255.255.0

Switch(config-if)#no sh

Switch(config-if)#exit

Switch(config)#ip default-gateway 192.168.0.1

Switch(config)#enable password aaa

Switch(config)#line vty 0 ?

Switch(config)#line vty 0 15

Switch(config-line)#password aaa

Switch(config-line)#login

VLAN 间路由

Switch(config-if)#switchport mode trunk

Router(config)#interface gigabitEthernet 6/0

Router(config-if)#no sh

Router(config)#interface gigabitEthernet 6/0.1

Router(config-subif)#encapsulation dot1Q 1

Router(config-subif)#ip address 192.168.0.1 255.255.255.0

带路由模块的交换机实现 VLAN 间路由

两台交换机配置 trunk :

C onf t

I nterface f0/0

S witchport mode trunk

S witchport trunk encapsulation dot1q/isl

S witchport trunk allowed vlan 1,4

S witchport trunk allowed vlan 1-4

S witchport trunk allowed except vlan 1-2

生成树( STP )

S panning-tree vlan 2

N o spanning-tree vlan 2 打开与关闭树

S panning-tree vlan 2 root primary 设置主 root 根网桥

S panning-tree vlan 3 root secondary 设置备份 root 备份网桥

S panning-tree vlan 3 priority 8192 设置优先级( 0 , 4096 , 8192. 。。。到 61440 )

配置可选功能:

S panning-tree backbonefast ( 不是连接 本交换机的链路失效时 ) 30 秒

S panning-tree uplinkfast ( 连接本交换机链路失效 1-5 分钟

S panning-tree uplinkfast max-update-rate (0-32000)

S panning-tree portfast default

S panning-tree portfast bpdufilter default

路由器:

I nternet 就是用路由器加专线的方法连接了成千上万个网络而构成的

路由选择的核心就是确定下一跳路由器的 IP 地址

路由表是路由选择的核心

路由表主要内容:目的网络地址,下一跳路由器地址和目的端口等信息,缺省 路

由信息

分组转发通常称分组交换

缺省路由又称缺省网关,一般路由器的缺省网关是指向连往 Internet 出口的路 由

几种路由协议管理距离:

直接连接: 0 静态路由: 1 外部 BGP : 20 内部 EIGRP : 90 IGRP : 100

OSPF : 110 RIP:120 外部 EIGRP : 170 内部 BGP : 200 未知: 255

路由配置常用命令

Router# write memory 保存到路由器的 NVRAM 中

Router# write network tftp 保存到 tftp 服务器

Router# write erase 删除路由器全部配置

show interface 查看路由器的接口

show running-config 查看路由的配置 密码 接口 IP 地址 ACL NAT

show version 查看路由器版本 配置寄存器的值

show ip route 查看路由表

show ip protocal 查看路由器运行的动态路由协议

config t

Router(config)#

Router(config)#hostname Router1

Router1(config)#enable password aaa

Router1(config)#enable secret aaaa

配置 Telnet Telnet Telnet Telnet 密码 TCP 23

Router1(config)#line vty 0 4

Router1(config-line)#password aaa 设置 Telnet 密码

Router1(config-line)#login 要求必须登录

Telnet 如果不需要密码执行以下命令

Router1(config)#line vty 0 4

Router1(config-line)#no login

Router1(config-line)#no password

配置路由器接口 IP IP IP IP 地址

Router1(config)#interface fastEthernet 0/0

Router1(config-if)#ip address 192.168.0.1 255.255.255.0

Router1(config-if)#no sh

Router1(config)#interface serial 2/0

Router1(config-if)#clock rate 64000 在 DCE 端配置时钟频率

Router1(config-if)#ip address 10.0.0.1 255.255.255.0

Router1(config-if)#no sh

管理 Cisco 互联网络

路由器的结构:中央处理器 CPU; 内存 MENORY ;存储器 Storage ;接口:

INTERFACE

内存 :

RAM 相当于计算机的内存 配置路由器的设置默认是 RAM

NVRAM 相当于硬盘存放 startup-config 32kb-128kb

ROM 相当于计算机的 BIOS , 不能删除 存放 Bootstarp POST 微型 IOS

Flash 存放 IOS

路由器工作模式(用户模式;特权模式;设置模式;全局配置模式;其他配置 模

式; RXBOOT 模式

恢复路由器密码

Router#show version

Configuration register is 0x2102

重启路由器

Ctrl+breack 中断路由器正常启动

rommon 2 > confreg 0x2142

Router#copy startup-config running-config

Router(config)#enable secret aaaa

Router#copy running-config startup-config

Router(config)#config-register 0x2102

密码恢复成功

修改配置寄存器

在 2600 系列命令

Rommon 1 > confreg 0x2142

输入 Reset

配置 2500 系列命令

产生中断后输入 o ,再输入 o/r 0x2142

输入 I (初始化)

备份和升级路由器 IOS IOS IOS IOS

r5#copy flash tftp 备份系统

r5#copy tftp flash 升级系统

解析主机名

Router(config)#ip host Router0 172.16.5.1

Router#telnet Router0

网络排错

ipconfig /all 查看计算机的 IP 配置,包括 IP 地址,子网掩码、网关 DNS 服务

器设置

ping 网关 IP 地址

ping 202.99.160.68 or 202.99.168.8 测试到 Internet 的网络层是否通

ping www.inhe.net 域名是否能解析成 IP 地址

telnet www.inhe.net 80 测试应用层是否畅通 23 默认端口

pathping www.inhe.net 跟踪数据包路径和计算丢包情况

tracert ip 类似与计算机上的 pathping 能够跟踪数据包路径 不计算机丢包情况

Router#debug ip packet

Router#debug ip ?

icmp ICMP transactions

nat NAT events

ospf OSPF information

packet Packet information

rip RIP protocol transactions

routing Routing table events

Router#undebug all

静态路由 管理员告诉路由器到各个网段如何转发

Router(config)#ip route 192.168.6.0 255.255.255.0 192.168.1.2 ?(可以更改管理 距

离 AD )

路由汇总

ip route 192.168.0.0 255.255.252.0 19

默认路由 代表大多数网段的路由

优先级最低

末端网络路由器使用默认路由减少路由表项

骨干网路由器通过路由汇总减少路由表项

动态路由 路由器自己来学习到各个网段如何转发

静态路由不能自动根据网络变换而变化 规模小 没有环

在计算机上添加路由表

route add 192.168.2.0 mask 255.255.255.0 192.168.1.2 添加路由表

route print 显示计算机上的路由表

netstat -r

动态路由

网络规模较大 or 具有网状结构的网络

RIP 周期性广播路由表 30 秒 度量值是跳数 15 跳 16 跳认为不可到达

RIPv1 广播传播路由信息 支持等长子网 不支持变长子网和不连续子网

RIPv2 多播传播路由信息 支持变长子网 和 不连续子网(关闭自动汇总)传 播

路由信息中包含了子网掩码信息

EIGRP 相当于 RIPv2 支持变长子网 关掉汇总,支持不连续子网。

Router#config t

Router(config)#router rip

Router(config-router)#network 172.16.0.0

Router(config-router)#network 10.0.0.0

Router(config-router)#version 2

Router(config-router)#no auto-summary

EIGRP 协议 非周期性更新路由信息, Hello 报文发现和跟踪邻居 以太网 5 秒 , T1

或更低的速率 Hello 报文以单播方式 60 秒发送一次, 3 倍时间确认失效,使用

224.0.0.10 用户邻居发现和回复,邻居使用单播地址确认 度量值默认带宽和延 迟

支持大的网络默认 100 跳 最大 255 跳 必须是统一自制区域才能交换路由信息

支持变长子网和不连续子网(关闭自动汇总) 收敛速度块(有备用路径) Cis co

专有协议

度量值 可以包括 跳数 带宽 延迟 负载 可靠性 代价( cost )

( Router#show ip protocols 显示配置的所有动态路由协议

Router(config)#router eigrp 10

Router(config-router)#network 192.168.0.0

Router(config-router)#no auto-summary )不要求掌握

路由信息可信度 值越低优先级越高

直连的网络 0

静态路由 1 ip route 10.0.0.0 255.0.0.0 192.168.1.1 121

EIGRP 90

OSPF 110

RIP 120

OSPF 路由表 由路由根据链路状态数据库算出来的,不出现环路,路由器之间

更新的是链路状态,度量值带宽。触发式更新。

路由器三个表 邻居表,链路状态表,路由表

特性

有地区和自制系统组成 最小化路由更新流量

可扩展 支持变长子网

跳数不受限 标准 开放的标准

OSPF 配置

Router(config)#router ospf 110 进程号

Router(config-router)#network 172.16.0.0 0.0.255.255 area 0 区域号 只有同一个

区域的接口才能交换链路状态信息

Router(config-router)#network 172.16.0.1 0.0.0.0 area 0

查看路由表

show ip route

查看链路状态数据库

Router#show ip ospf databases

查看邻居

Router#show ip ospf neighbor

更改 DR BDR 选举优先级

Router(config-if)#ip ospf priority 2

三层交换解决了 VLAN 间路由速度问题

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#router ospf 63

Router(config-router)#network 131.107.25.1 0.0.0.0 area 0

Router(config-router)#network 133.181.0.0 0.0.255.255 area 0

Router(config-router)#area 0 range 212.37.123.0 255.255.255.0

Router(config-router)#passive-interface ethernet 0

Router(config-router)#passive-interface vlan37

Router(config-router)#end

Router(config)#access-list 12 deny any

Router(config)#router ospf 63

Router(config-router)#distribute-list 12 in serial 0

DHCP 配置:

D iscover ( broadcast ) ---offer ( unicast ) ---request ( broadcast ) ---pack ( unicast )

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#ip dhcp pool zhao

Router(dhcp-config)#network 201.23.98.0 255.255.255.0

Router(dhcp-config)#network 201.23.98.0/24

Router(config)#ip dhcp excluded-address 201.23.98.2 201.23.98.10

Router(config)#ip dhcp excluded-address 201.23.98.193

Router(config)#ip dhcp pool zhao

Router(dhcp-config)#default-router 201.23.98.1

Router(dhcp-config)#domain-name zhao.com

Router(dhcp-config)#dns-server address 212.105.129.27 212.105.129.26

Router(dhcp-config)#lease 0 5 day hours min

访问控制列表:

适合所有网络层协议,如 IP IPX

功能 : 过滤流入流出数据包,限制网络流量,限制用户和设备对网络的访问,减

少网络欺骗和拒绝服务,提高网络安全性

提供基于源地址,目的地址,各种协议和端口号的过滤准则

分类(标准访问控制列表 1-99 1300-1999 ;扩展访问列表 100-199 2000-2699 )

IP 访问控制列表是一个连续的列表,至少由一个 permit 语句和一个或多个 deny

语句组成

只允许 xx 子网内主机登陆路由器

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#access-list 10 permit 211.105.130.0 0.0.0.255

Router(config)#line vty 0 5

Router(config-line)#access-class 10 in

只允许 xx 主机登陆路由器

Router(config)#access-list 20 permit 182.105.130.111

Router(config)#access-list 20 permit 222.112.7.56

Router(config)#access-list 20 deny any any

Router(config)#line vty 0 5

Router(config-line)#access-class 20 in

禁止源地址是非法地址的数据包进出路由

Router(config)#access-list 30 deny 10.0.0.0 0.255.255.255 log

Router(config)#access-list 30 deny 192.168.0.0 0.0.255.255

Router(config)#access-list 30 permit any

Router(config)#interface g0/1

Router(config)#ip access-group 30 in

拒绝所有 IP 地址进出,端口为 1434 的 UDP 协议数据包

Router(config)#access-list 130 deny udp any any eq 1434

Router(config)#access-list 130 permit ip any any

Router(config)#interface g0/1

Router(config)#ip access-group 130 in

Router(config)#ip access-group 130 out

格式:

access-list number permit tcp 源地址 源掩码 目的地址 目的掩码 eq 端口

deny udp lt(<)

gt(>)

neq 不等于

辑22

封闭一台主机

Router(config)#access-list 110 deny ip host 202.112.60.44 any log

Router(config)#access-list 110 deny ip any host 202.112.60.44 log

Router(config)#access-list 110 permit ip any any

Router(config)#interface g6/0

Router(config-if)#ip access-group 110 in

Router(config-if)#ip access-group 110 out

进入扩展访问控制列表配置模式

Router(config)#ip access-list extended 130

Router(config-ext-nacl)#deny udp any any eq 1434

Router(config-ext-nacl)#permit ip any any

Router(config-ext-nacl)#ex

Router(config)#interface g6/0

Router(config-if)#ip access-group 130 in

Router(config-if)#ip access-group 130 out

格式基本同 注意区分

ip access-list extended list-number

standard name

permit udp 源地址 源掩码 目的地址 目的掩码 eq 端口

deny tcp lt neq gt

无线局域网设备安装与调试

常用无线标准:蓝牙标准, Hiperlan 标准, IEEE802.11 标准

蓝牙软件结构标准包括核心和应用协议栈两个部分

HiperLAN 欧洲应用无线标准之一 主要技术特点:

高速数据传输;面向连接; qos ;自动频率分配;安全性;移动性;网络与应用

无关;省电

802.11b 是使用最广泛的标准

802.11b 分为两种运作模式(点对点模式;基本模式)

802.11b 典型解决方案(对等解决方案;单接入点 ~ ;多接入点 ~ ;无线中继 ~ ; 无

线冗余 ~ ;多蜂窝漫游工作方式)

无线局域网设计 ( 初步调查;对现有环境进行分析;制定初步设计;确定详细设

计;执行和实施设计;整理文档 )

无线接入点也称无线 AP 一般可以连接 30 台

网络安全与管理技术

网络安全基本要素(保密性;完整性;可用性;可鉴别性;不可否认性)

信息泄露与篡改(截获信息;窃听信息;篡改信息;伪造信息)

网络攻击(服务攻击与非服务攻击)

服务攻击:指对网络提供各种服务的服务器发起攻击,造成网络拒绝服务,表 现

在消耗带宽,消耗计算资源,使系统和应用崩溃

SYN 攻击时一种典型的拒绝服务攻击

非服务攻击:不针对某项应用服务,而是针对网络层等低协议进行的

源路由攻击和地址欺骗都属于这一类

非服务攻击更为隐蔽,是种更为危险的攻击手段

非授权访问以及网络病毒

目前 70% 的病毒发生在网络上

设计一个网络安全方案时 需要完成四个基本任务

( 1 ) 设计一个算法,执行安全相关的转换

( 2 ) 生成该算法的秘密信息(如密匙)

( 3 ) 研制秘密信息的分发与共享的方法

( 4 ) 设定两个责任者使用的协议,利用算法和秘密信息取得安全服务

P2DR 安全模型

包括 :策略 防护 检测 响应

数据备份:

完全备份:恢复速度最快 空间使用最多 备份速度最慢

增量备份:恢复速度最慢 空间使用最少 备份速度最快、

差异备份:中间性能

冷备份: 又叫离线备份 恢复时间长 投资少

热备份 又称在线备份 很大的问题是数据的有效性和完整性

加密技术:

密码学包括密码编码学与密码分析学

密码体制是密码学研究的主要内容

现在密码学基本原则:一切密码属于密匙之中。在设计加密系统时,加密算法 是

可以公开的,真正需要保密的是密钥

猜测每 10 的六次方个密钥要用 1 微秒的时间

数据加密标准 DES 是最典型的对称加密算法,采用 64 位密钥长度, 8 位用于 奇

偶校验,用户使用其中的 56 位

非对称加密技术:对信息加密解密使用不同的密钥,用来加密的密钥是可以公 开

的,解密的密钥是用来保密的,又称公钥加密技术

计算机病毒的主要特征:非授权可执行性;隐蔽性;传染性;潜伏性;

计算机病毒分类

寄生方式(引导型,文件型,复合型)

按破坏性(良性,恶性)

网络病毒特征:传播方式多样,传播速度更快;影响面更广;破坏性更强;难 以

控制和根治;编写方式多样,病毒变种多,智能化,混合病毒

恶意代码:

蠕虫(计算机蠕虫是一个自我包含的程序或程序集,能够传播自身并拷贝自身)

分为宿主计算机蠕虫和网络蠕虫

木马(木马是没有自我复制功能的恶意程序)

木马传播途径:电子邮件,软件下载,通过会话软件

根据防火墙的实现技术:可以将防火墙分为包过滤路由器,应用级网关,应用 代

理和状态检测等

目前市场上的主流防火墙,一般都是状态检测防火墙

防火墙系统结构分为:包过滤路由器结构;双宿主主机结构;屏蔽主机结构; 屏

蔽子网结构

此部分详细看书 ~~

防火墙配置:

P ix525(config)#nameif ethernet0 outside security0

P ix525(config)#nameif ethernet1 inside security100

P ix525(config)#nameif dmz security50

P ix525(config)#interface ethernet0 auto

P ix525(config)#interface ethernet1 100full

P ix525(config)#ip address outside 202.113.79.1 255.255.255.240

P ix525(config)#ip address inside 192.168.0.1 255.255.255.0

指定内网访问外网的主机,与 global 一起使用

P ix525(config)#nat (inside) 1 192.168.0.1 255.255.255.0

I nside 是默认的内网接口名字 1 是 id

P ix525(config)#global(outside) 1 202.113.79.1-202.113.79.14

定义可分配的全局 ip 地址

设置指向内网和外网的静态路由

P ix525(config)#route outside 0 0 210.81.20.1 1

格式: if _name 0 0 ip metric

outside 是接口名字 ip 是路由网关 1 是跳数(默认是 1 )

P ix525(config)#static(inside,outside) 202.113.79.4 192.168.0.4

建立静态映射

P ix525(config)#conduit permit tcp host 192.168.0.4 eq www any

C onduit permit tcp ip 端口 外部 ip

deny udp any

icmp host+ip

( 是全局 ip )

P ix525(config)#fixup protocol http 80

P ix525(config)#no fixup protocol smtp

启动 http 协议 指定 80 禁止 smtp

 

我猜你可能也喜欢:

No Comments - Leave a comment

Leave a comment

电子邮件地址不会被公开。 必填项已用*标注

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>


Welcome , today is 星期六, 2017 年 10 月 21 日